Back to overview
Resolved
Game Panel is unavailable
Nov 17, 2024 at 6:21pm UTC
Resolved
Nov 17, 2024 at 6:30pm UTC
We’re back! The Game Panel should be up and running. Thanks for bearing with us.
Affected services
Created
Nov 17, 2024 at 6:21pm UTC
We’re investigating an issue with the Game Panel that is impacting some users. We’re working to fix the problem as quickly as we can. We’ll share another update shortly.
Affected services