Back to overview
Resolved

Degraded Network

Mar 6, 2024 at 7:50pm UTC

Resolved
Mar 6, 2024 at 8:55pm UTC

The issue was resolved.

Updated
Mar 6, 2024 at 8:51pm UTC

We've made some improvements and are now conducting final testing to ensure the network stability.

Created
Mar 6, 2024 at 7:50pm UTC

We noticed a issue with our DDoS Protection provider and we are working with them to resolve the issue.