Back to overview
Resolved

Network Problems

Sep 20, 2023 at 7:26pm UTC

Resolved
Sep 20, 2023 at 7:45pm UTC

The problem was fixed.

Updated
Sep 20, 2023 at 7:30pm UTC

The cause of this has been identified and the a fix will be applied.

Created
Sep 20, 2023 at 7:26pm UTC

We want to inform you that our Germany server is currently experiencing some issues, including packet loss and/or player disconnections. Our team is already aware of the situation and actively investigating the root cause. We apologize for any inconvenience this may cause and appreciate your patience and support during this time.

We will keep you updated on our progress and notify you as soon as the issues are resolved.