Back to overview
Resolved
Routing Amsterdam
Mar 23, 2023 at 4:57pm UTC
Resolved
Mar 23, 2023 at 7:00pm UTC
We’ve fixed the routing.
Affected services
Created
Mar 23, 2023 at 4:57pm UTC
We have noticed increased latency to Amsterdam, we are working on it now.
Affected services