Back to overview
Resolved
Decreased Firewall Performance
Sep 7, 2022 at 4:14pm UTC
Resolved
Sep 7, 2022 at 4:14pm UTC
We are currently dealing with a large amount of DDoS Attacks against our website. The Website might be unavailable for some user. Our team is already working on a permanent fix.
Affected services