Cotoax - Scaling Network Capacity for Increased DDoS Activity – Incident details

Scaling Network Capacity for Increased DDoS Activity

Resolved
Under maintenance
Started 3 months agoLasted about 1 month

Affected

DDoS Protection

Under maintenance from 8:12 PM to 7:55 PM

Game Shield

Under maintenance from 8:12 PM to 7:55 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    Over the past several days, we have made significant progress toward increasing overall network capacity and reworking key components of our DDoS mitigation architecture.

    These upgrades are currently in the testing and validation phase. Early results are positive and we are seeing substantial improvements in our ability to withstand large scale attacks. This work is focused on expanding network level capacity, application layer protections remain fully functional.

    We will continue to provide updates as testing completes and changes are rolled out.

  • Identified
    Identified

    Due to the continued increase in the size of DDoS attacks, we will be taking action in the near future to increase our network capacity so we can better withstand these attacks. There is no issue with our application layer filtering itself, the current limitation is overall network capacity.

    Over the past 30 days, we have observed an average attack size of approximately 2 Tbps, which exceeds our existing network capacity. We will provide further updates as progress is made.